Troubleshooting

From SatNOGS
Revision as of 13:13, 20 August 2019 by Bmorchard (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Client troubleshooting

Client not showing up on the network?

  • Check that you have ticked the "Is it operational?" checkbox on the groundstation page.
  • Check your settings and ensure that the API token and station ID are correct. You can get these from your profile page on the SatNOGS network site. If you have accounts in both dev and prod, make sure you're using the token and station ID from the right environment.
  • Check your SATNOGS_NETWORK_API_URL. It should point to https://network.satnogs.org/api/ (prod) or https://network-dev.satnogs.org/api/ (dev).
  • Check your network connectivity. Can you ping network.satnogs.org or network-dev.satnogs.org? Try running curl https://network.satnogs.org or curl https://network-dev.satnogs.org.
  • Check the logs for an error (journalctl -f -u satnogs-client.service or less /var/log/supervisor/satnogs-error.log) and post to our forums at https://community.libre.space

"satnogsclient - ERROR - Cannot connect to socket 127.0.0.1:4533"

The client is trying to connect to rotctld but is unable to.

  • If you have a no-rotator setup, ensure that satnogs-client is configured as such; see the Raspberry Pi 3 page for info on how to do this.
  • If you do have a rotator, ensure that rotctld is running.


Some uploads missing & Doppler-correction not working properly

The station/client might have a clock offset. This causes a Doppler shift on the waterfall and some observations don't start because of a conflict between the time on the PC of the station and the time of the SatNOGS Network.

Signal troubleshooting

Blank or solid purple waterfall?

At the first sign of trouble, put your station into testing mode. This way bad waterfalls do not get uploaded to the database.

  • Make sure the RTLSDR gain is set correctly. If set too high, a blank waterfall can result. If set to low, same. Test a value between 7 and 15.
    Check your gain value is valid. Wrong values can result in blank waterfalls. For for example '7.7.' will result in errors (and a blank waterfall - there is an extra '.' at the end).
    journalctl -u satnogs-client.service It might be a big file, but work through it and look for errors.
    df -h Ensure there is sufficient hard drive space. If temp files can not be created, the waterfall might be blank.
    Run rtl_test for about 30 seconds and make sure you can connect with the dongle and that there are no errors.

Not receiving anything?

  • Make sure the satellite you are testing observations against is active and recently received by others on our production network site. If you click on a satellite name, a popup will appear and give you the option to click on "Past Observations". If everything in the past shows red, then the problem is likely with that satellite.
  • SO-50 is a good satellite to use for testing as it is a strong FM voice signal assuming you have UHF capabilities. Schedule using "PE0SAT - Mode V/U FM Voice - 436.794 MHz". Here is an example to compare against: https://network.satnogs.org/observations/3334/
  • ISS is a good test for VHF as the APRS digipeater is alive again (as of this writing; check issfanclub.com for up-to-date information). When you schedule it, be sure to select the APRS downlink.
  • If you're using an rtlsdr, check that it can be seen and is operating correctly by running rtl_test. Let it run for 30 seconds or so, then hit Ctrl-c to kill it:
pi@raspberrypi:~ $ rtl_test 
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode...
^CSignal caught, exiting!

User cancel, exiting...
Samples per million lost (minimum): 0
  • You can also try a manual run of satnogs_fm_demod.py to make sure that works:
$ cd /tmp
$ satnogs_fm_demod.py --rx-sdr-device=rtlsdr --rx-freq=444000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat

Let it run for a minute or so. If everything is working, this should create an .ogg file and a .dat file of non-zero size (probably a few MB each).

Check your location!

Observations seem off-frequency?

  • PPM drift While newer SDR devices are very good and stable, there still may be some PPM drift to compensate for if you notice that signals are consistently off center. The SATNOGS_PPM_ERROR setting in /etc/supervisord.d/satnogs.ini can be used to correct for this.
  • Clock sync Make sure your clock is synced. Ensure ntp is configured and running (especially with the Raspberry Pi which lacks a real time clock)
  • Wrong location If your signal seems to be on but drifts at the apex like in this image, check to make sure your Latitude, Longitude, and Elevation coordinates are set properly and in the right format.
RF Noise
Too much RF Noise

RF Noise

If you notice a noise in the waterfall every time motors are spinning, you will need to:

  • Twist each pair or the motor wire
  • Add proper grounding
  • Add capacitor to the DC input of drivers
  • wrap the motors wire with adhesite aluminum and then connect it to GND on driver side
  • add ferites to motors wires