Difference between revisions of "Linux Desktop"

From SatNOGS
m (Install gr-satnogs)
Line 1: Line 1:
 +
{{Warning|This page provides deprecated or unsupported information, please consider using [[SatNOGS Client Ansible]] instructions for installing SatNOGS client on a linux machine}}
 +
 
'''This article to create a Linux Desktop client is not currently working.  Use it as a hints and kinks rather than a cookbook.'''
 
'''This article to create a Linux Desktop client is not currently working.  Use it as a hints and kinks rather than a cookbook.'''
  

Revision as of 18:36, 22 June 2018

Important.png
This page provides deprecated or unsupported information, please consider using SatNOGS Client Ansible instructions for installing SatNOGS client on a linux machine

This article to create a Linux Desktop client is not currently working. Use it as a hints and kinks rather than a cookbook.

Here you will find instructions on installing SatNOGS to a Linux Desktop running Ubuntu 16.04 LTS.

Prep Work

Install dependencies

sudo apt-get update
sudo apt-get install -y python-pip python-dev supervisor cmake libusb-1.0-0-dev libhamlib-utils vorbis-tools software-properties-common unzip  

Install gnuradio libs from myriadrf since we need a newer version than Ubuntu provides for 16.04

sudo apt-get purge --auto-remove libgnuradio*
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo apt-get update
sudo apt-get install -y gnuradio-dev libboost-dev libnova-dev libpng-dev

Install gr-satnogs

Grab the latest gr-satnogs debian package, unpack it, and install the appropriate deb file:

wget -O archive.zip https://gitlab.com/librespacefoundation/satnogs/gr-satnogs-package/-/jobs/35403119/artifacts/download  (broken link here)
unzip archive.zip -d gr-satnogs

Install satnogs client

pip install satnogsclient